DroneMobile Phone & Operating Systems (OS) Requirements

  • Apple – Requires iOS 10.3 or later.
    • Examples of Compatible Apple Devices:
      • iPhone – 5 and newer.
      • iPad – iPad (4th Generation), Mini 2 and newer, iPad Air, iPad Pro
      • iPod – Touch (6th Generation)
  • Android – Requires Android 5.0 or later. *However, not all Android phones allow for upgrades of 5.0 or later. *
    • Examples of Compatible Android Devices:
      • Samsung – Galaxy Note 3 and newer. Galaxy S4 and newer.
      • LG – G2, G3 or newer
      • Motorola – Moto X, Moto G, Moto E, Droid Ultra/Maxx/Mini, and newer.
      • HTC – HTC One Max, HTC One M7 and newer.
      • Sony – Xperia Z2 and newer.
      • Nexus – Nexus 4 and newer.

*If you’re using a device purchased before January 2014, it’s possible that it won’t be compatible with the DroneMobile app. If you’re not sure, please check with your cellular provider. * 

You will also need an email address to be able to register your DroneMobile account. (https://accounts.dronemobile.com/UserLogin/IsSerialNumberRegistrable)

We will use that email address to send you important notices regarding your device and upcoming subscription promotions. It’s also important that you use an email that only you have access to and that you don’t share your DroneMobile account information.  

For any questions, contact DroneMobile support here: https://support.dronemobile.com/hc/en-us/requests/new

Follow
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.